Video

'It is I' vs. 'It's me'

Flash Player Required

Which is right? The answer is complicated. The Adobe Flash Player is required in order to view this content. You can get it here:
Get Adobe Flash player